summaryrefslogtreecommitdiffstats
path: root/bin/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bin/tools/CMakeLists.txt')
-rw-r--r--bin/tools/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/bin/tools/CMakeLists.txt b/bin/tools/CMakeLists.txt
new file mode 100644
index 0000000..a52bb97
--- /dev/null
+++ b/bin/tools/CMakeLists.txt
@@ -0,0 +1,40 @@
+cmake_minimum_required(VERSION 2.8)
+
+add_definitions("--std=c99 -Wall")
+
+# --- Find packages and libraries ---------------------------------------------
+find_package(TIFF)
+
+# --- Build targets -----------------------------------------------------------
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+
+set(libs uca)
+
+if (TIFF_FOUND)
+ set(HAVE_LIBTIFF "1")
+ list(APPEND libs ${TIFF_LIBRARIES})
+ include_directories(${TIFF_INCLUDE_DIRS})
+endif ()
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+# --- gen-doc
+add_executable(gen-doc gen-doc.c)
+target_link_libraries(gen-doc ${libs})
+
+# --- uca-grab
+add_executable(uca-grab grab.c)
+target_link_libraries(uca-grab
+ ringbuffer
+ ${libs})
+
+# --- uca-benchmark
+add_executable(benchmark benchmark.c)
+target_link_libraries(benchmark ${libs})
+
+install(TARGETS uca-grab
+ RUNTIME DESTINATION bin)