summaryrefslogtreecommitdiffstats
path: root/bin/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-04-11 08:53:29 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-04-11 08:54:12 +0200
commit06d5b3438f682307db06074ce9709b949a9aa846 (patch)
tree99dbeeab1eeab0d890ad1a32842ffb3540c782c5 /bin/tools/CMakeLists.txt
parent1cb1a541bedd4e17085ab8ce04d0f5b2fc4d8d1d (diff)
downloaduca-06d5b3438f682307db06074ce9709b949a9aa846.tar.gz
uca-06d5b3438f682307db06074ce9709b949a9aa846.tar.bz2
uca-06d5b3438f682307db06074ce9709b949a9aa846.tar.xz
uca-06d5b3438f682307db06074ce9709b949a9aa846.zip
Move binaries to bin and make ring buffer a lib
Diffstat (limited to 'bin/tools/CMakeLists.txt')
-rw-r--r--bin/tools/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/bin/tools/CMakeLists.txt b/bin/tools/CMakeLists.txt
new file mode 100644
index 0000000..a52bb97
--- /dev/null
+++ b/bin/tools/CMakeLists.txt
@@ -0,0 +1,40 @@
+cmake_minimum_required(VERSION 2.8)
+
+add_definitions("--std=c99 -Wall")
+
+# --- Find packages and libraries ---------------------------------------------
+find_package(TIFF)
+
+# --- Build targets -----------------------------------------------------------
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+
+set(libs uca)
+
+if (TIFF_FOUND)
+ set(HAVE_LIBTIFF "1")
+ list(APPEND libs ${TIFF_LIBRARIES})
+ include_directories(${TIFF_INCLUDE_DIRS})
+endif ()
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+# --- gen-doc
+add_executable(gen-doc gen-doc.c)
+target_link_libraries(gen-doc ${libs})
+
+# --- uca-grab
+add_executable(uca-grab grab.c)
+target_link_libraries(uca-grab
+ ringbuffer
+ ${libs})
+
+# --- uca-benchmark
+add_executable(benchmark benchmark.c)
+target_link_libraries(benchmark ${libs})
+
+install(TARGETS uca-grab
+ RUNTIME DESTINATION bin)