summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorTimo Dritschler <timo.dritschler@kit.edu>2014-11-20 17:37:55 +0100
committerTimo Dritschler <timo.dritschler@kit.edu>2014-11-20 17:53:19 +0100
commit65c2326592b7b1496c468459689904843e443b26 (patch)
tree7dc907bc82227851bc8e13827ae25cbabcf9ba1f /test/CMakeLists.txt
parente71b75575658c435bc77c01ef098336c563af740 (diff)
downloadkiro-65c2326592b7b1496c468459689904843e443b26.tar.gz
kiro-65c2326592b7b1496c468459689904843e443b26.tar.bz2
kiro-65c2326592b7b1496c468459689904843e443b26.tar.xz
kiro-65c2326592b7b1496c468459689904843e443b26.zip
Release KIRO to GitHub under LGPL v2.1
Added kiro_*_free methods to all three units Added installation guide Added readme Added licence file
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index a37c16c..a3f7777 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -5,15 +5,19 @@ find_package(PkgConfig)
pkg_check_modules(SDL sdl>=1.2.15)
if (SDL_FOUND)
- add_executable(client-sdl test-client.c)
- target_link_libraries(client-sdl kiro SDL m gobject-2.0 glib-2.0)
+ add_executable(kiro-client-sdl test-client.c)
+ target_link_libraries(kiro-client-sdl kiro SDL m gobject-2.0 glib-2.0)
+ install(TARGETS kiro-client-sdl RUNTIME DESTINATION bin)
else ()
message("SDL not found: Won't build KIRO test-client-sdl binary.")
endif ()
add_executable(kiro-test-latency test-client-latency.c)
target_link_libraries(kiro-test-latency kiro gobject-2.0 glib-2.0)
-add_executable(kiro-test-bandwith test-client-bandwith.c)
-target_link_libraries(kiro-test-bandwith kiro gobject-2.0 glib-2.0)
-add_executable(server test-server.c)
-target_link_libraries(server kiro gobject-2.0 glib-2.0)
+add_executable(kiro-test-bandwidth test-client-bandwidth.c)
+target_link_libraries(kiro-test-bandwidth kiro gobject-2.0 glib-2.0)
+add_executable(kiro-server test-server.c)
+target_link_libraries(kiro-server kiro gobject-2.0 glib-2.0)
+
+install(TARGETS kiro-test-bandwidth kiro-test-latency kiro-server
+ RUNTIME DESTINATION bin)