summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorTimo <timo.dritschler@kit.edu>2014-09-30 14:55:26 +0200
committerTimo <timo.dritschler@kit.edu>2014-09-30 14:55:26 +0200
commite71b75575658c435bc77c01ef098336c563af740 (patch)
treedd2d852820339cf84df216e62a76ebbda9d32fc0 /test/CMakeLists.txt
parent6ffe22890f901238318c68c38c099ccd62321a9a (diff)
downloadkiro-e71b75575658c435bc77c01ef098336c563af740.tar.gz
kiro-e71b75575658c435bc77c01ef098336c563af740.tar.bz2
kiro-e71b75575658c435bc77c01ef098336c563af740.tar.xz
kiro-e71b75575658c435bc77c01ef098336c563af740.zip
Fixed a bug in RDMA memory allocation (Size information was missing)
Added test-latency and test-bandwith tests
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index aee6c45..a37c16c 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -5,11 +5,15 @@ find_package(PkgConfig)
pkg_check_modules(SDL sdl>=1.2.15)
if (SDL_FOUND)
- add_executable(client test-client.c)
- target_link_libraries(client kiro SDL m gobject-2.0 glib-2.0)
+ add_executable(client-sdl test-client.c)
+ target_link_libraries(client-sdl kiro SDL m gobject-2.0 glib-2.0)
else ()
- message("SDL not found: Won't build KIRO test-client binary.")
+ message("SDL not found: Won't build KIRO test-client-sdl binary.")
endif ()
+add_executable(kiro-test-latency test-client-latency.c)
+target_link_libraries(kiro-test-latency kiro gobject-2.0 glib-2.0)
+add_executable(kiro-test-bandwith test-client-bandwith.c)
+target_link_libraries(kiro-test-bandwith kiro gobject-2.0 glib-2.0)
add_executable(server test-server.c)
target_link_libraries(server kiro gobject-2.0 glib-2.0)