summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-04-11 08:53:29 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2013-04-11 08:54:12 +0200
commit06d5b3438f682307db06074ce9709b949a9aa846 (patch)
tree99dbeeab1eeab0d890ad1a32842ffb3540c782c5 /tools/CMakeLists.txt
parent1cb1a541bedd4e17085ab8ce04d0f5b2fc4d8d1d (diff)
downloaduca-06d5b3438f682307db06074ce9709b949a9aa846.tar.gz
uca-06d5b3438f682307db06074ce9709b949a9aa846.tar.bz2
uca-06d5b3438f682307db06074ce9709b949a9aa846.tar.xz
uca-06d5b3438f682307db06074ce9709b949a9aa846.zip
Move binaries to bin and make ring buffer a lib
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
deleted file mode 100644
index b16f018..0000000
--- a/tools/CMakeLists.txt
+++ /dev/null
@@ -1,42 +0,0 @@
-cmake_minimum_required(VERSION 2.8)
-
-add_definitions("--std=c99 -Wall")
-
-# --- Find packages and libraries ---------------------------------------------
-find_package(PkgConfig)
-find_package(TIFF)
-
-pkg_check_modules(GLIB2 glib-2.0>=2.24 REQUIRED)
-pkg_check_modules(GOBJECT2 gobject-2.0>=2.24 REQUIRED)
-
-# --- Build targets -----------------------------------------------------------
-include_directories(
- ${GLIB2_INCLUDE_DIRS}
- ${GOBJECT2_INCLUDE_DIRS}
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_CURRENT_SOURCE_DIR}
- ${CMAKE_CURRENT_SOURCE_DIR}/../src
- )
-
-set(libs uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
-
-if (TIFF_FOUND)
- set(HAVE_LIBTIFF "1")
- list(APPEND libs ${TIFF_LIBRARIES})
- include_directories(${TIFF_INCLUDE_DIRS})
-endif ()
-
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
- ${CMAKE_CURRENT_BINARY_DIR}/config.h)
-
-add_executable(gen-doc gen-doc.c)
-target_link_libraries(gen-doc ${libs})
-
-add_executable(uca-grab grab.c ring-buffer.c)
-target_link_libraries(uca-grab ${libs})
-
-add_executable(benchmark benchmark.c)
-target_link_libraries(benchmark ${libs})
-
-install(TARGETS uca-grab
- RUNTIME DESTINATION bin)