summaryrefslogtreecommitdiffstats
path: root/bin/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-10-29 09:05:51 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-10-29 09:05:51 +0100
commit137f03b9a34fb39e5321524ab11fa31276458476 (patch)
tree83ea6e2b2228d1e99a37a0e510faaa13130ef849 /bin/gui/CMakeLists.txt
parent85a0f33711fd4467b9027da85ab9e09e406398d4 (diff)
downloaduca-137f03b9a34fb39e5321524ab11fa31276458476.tar.gz
uca-137f03b9a34fb39e5321524ab11fa31276458476.tar.bz2
uca-137f03b9a34fb39e5321524ab11fa31276458476.tar.xz
uca-137f03b9a34fb39e5321524ab11fa31276458476.zip
Use ConfigurePaths to get installation paths
The advantage is twofold: 1) we have a clear separation between setting up the paths and actually using them, 2) the interface is very likely as configure scripts and makes integration into build system a bit easier.
Diffstat (limited to 'bin/gui/CMakeLists.txt')
-rw-r--r--bin/gui/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/bin/gui/CMakeLists.txt b/bin/gui/CMakeLists.txt
index bb5a8f4..a75b5b1 100644
--- a/bin/gui/CMakeLists.txt
+++ b/bin/gui/CMakeLists.txt
@@ -1,5 +1,8 @@
cmake_minimum_required(VERSION 2.6)
+#{{{ Variables
+set(UCA_GLADEDIR "${UCA_DATADIR}/libuca")
+#}}}
#{{{ Configure
find_package(PkgConfig)
@@ -32,9 +35,9 @@ if (GTK2_FOUND)
${GTHREAD2_LIBRARIES})
install(TARGETS ${BINARY}
- RUNTIME DESTINATION bin)
+ RUNTIME DESTINATION ${UCA_BINDIR})
install(FILES control.glade
- DESTINATION share/libuca)
+ DESTINATION ${UCA_GLADEDIR})
endif()
#}}}