summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt20
1 files changed, 16 insertions, 4 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 957fdbf..0e4d28e 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -16,9 +16,21 @@ include_directories(
${CMAKE_CURRENT_SOURCE_DIR}/../src
)
+set(libs uca ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES})
+
add_executable(gen-doc gen-doc.c)
+target_link_libraries(gen-doc ${libs})
-target_link_libraries(gen-doc uca
- ${GLIB2_LIBRARIES}
- ${GOBJECT2_LIBRARIES}
- )
+add_executable(grab grab.c)
+target_link_libraries(grab ${libs})
+
+add_executable(grab-async grab-async.c)
+target_link_libraries(grab-async ${libs})
+
+add_executable(benchmark benchmark.c)
+target_link_libraries(benchmark ${libs})
+
+add_executable(perf perf-overhead.c)
+target_link_libraries(perf ${libs})
+
+add_subdirectory(gui)