summaryrefslogtreecommitdiffstats
path: root/plugins/dexela/CMakeLists.txt
diff options
context:
space:
mode:
authorMihael Koep <koep@schneide.com>2013-03-27 14:37:39 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-06 14:43:09 +0100
commit60827d7d3639f289794d834a8d926c5930ce9527 (patch)
tree5b330e8df567d54710dcc669fb0da6808126b1ff /plugins/dexela/CMakeLists.txt
parent524a4de957d4d052a9fd10b097c8e61dc5820033 (diff)
downloadlibuca-60827d7d3639f289794d834a8d926c5930ce9527.tar.gz
libuca-60827d7d3639f289794d834a8d926c5930ce9527.tar.bz2
libuca-60827d7d3639f289794d834a8d926c5930ce9527.tar.xz
libuca-60827d7d3639f289794d834a8d926c5930ce9527.zip
Make dexela plugin-ready and bump version.
Diffstat (limited to 'plugins/dexela/CMakeLists.txt')
-rw-r--r--plugins/dexela/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/plugins/dexela/CMakeLists.txt b/plugins/dexela/CMakeLists.txt
index df939c3..794b811 100644
--- a/plugins/dexela/CMakeLists.txt
+++ b/plugins/dexela/CMakeLists.txt
@@ -1,17 +1,17 @@
cmake_minimum_required(VERSION 2.6)
project(ucadexela C)
-set(VERSION "1.0.0")
+set(VERSION "1.0.1")
find_package(DEXELA)
if (DEXELA_FOUND)
set(UCA_CAMERA_NAME "dexela")
- set(PLUGIN_REVISION "4")
- set(PLUGIN_VERSION "1.0.0")
+ set(PLUGIN_REVISION "1")
+ set(PLUGIN_VERSION ${VERSION})
set(PLUGIN_SUMMARY "Dexela plugin for libuca")
set(PLUGIN_CHANGELOG "${CMAKE_CURRENT_SOURCE_DIR}/changelog.txt")
set(PLUGIN_DESCRIPTION "Plugin for the Dexela 1207 detector.")
- set(PLUGIN_REQUIRES "libuca = 1.1.0, libdexela >= 0.9.2")
+ set(PLUGIN_REQUIRES "libuca = 1.1.0, libdexela >= 1.0.0")
set(PLUGIN_VENDOR "ANKA Computing Group")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/../package-plugin.sh.in
@@ -22,7 +22,7 @@ if (DEXELA_FOUND)
add_library(ucadexela SHARED uca-dexela-camera.c)
- target_link_libraries(ucadexela ${UCA_DEPS} ${DEXELA_LIBRARIES})
+ target_link_libraries(ucadexela ${UCA_DEPS} ${DEXELA_LIBRARIES})
install(TARGETS ucadexela
LIBRARY DESTINATION ${UCA_PLUGINDIR}