summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2013-11-13 21:55:22 +0100
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2013-11-13 21:55:22 +0100
commit6a273c8ff6332b4b53a315acfcc65b938ea4d782 (patch)
tree25fd6a785abd61e501b93f7d6fd5a245f788e90e /configure.in
parent4ecd877558d86495ffe83a62c4c3f276fec3f092 (diff)
downloadlibrcd-6a273c8ff6332b4b53a315acfcc65b938ea4d782.tar.gz
librcd-6a273c8ff6332b4b53a315acfcc65b938ea4d782.tar.bz2
librcd-6a273c8ff6332b4b53a315acfcc65b938ea4d782.tar.xz
librcd-6a273c8ff6332b4b53a315acfcc65b938ea4d782.zip
Merge build system fixes from LibRCC
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 0 insertions, 48 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 9e51720..0000000
--- a/configure.in
+++ /dev/null
@@ -1,48 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(src/librcd.c)
-AC_CONFIG_HEADERS(config.h)
-
-PACKAGE=librcd
-LIBRCD_VERSION_MAJOR=`cat VERSION | sed -e s/CVS// | cut -d . -f 1 | sed -e s/^$/0/`
-LIBRCD_VERSION_MINOR=`cat VERSION | sed -e s/CVS// | cut -d . -f 2 | sed -e s/^$/0/`
-LIBRCD_VERSION_SUBMINOR=`cat VERSION | sed -e s/CVS// | cut -d . -f 3 | sed -e s/^$/0/`
-LIBRCD_VERSION=$LIBRCD_VERSION_MAJOR.$LIBRCD_VERSION_MINOR.$LIBRCD_VERSION_SUBMINOR
-VERSION=$LIBRCD_VERSION
-LIBRCD_VERSION_INFO=`echo $LIBRCD_VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
-
-AC_SUBST(LIBRCD_VERSION)
-AC_SUBST(LIBRCD_VERSION_MAJOR)
-AC_SUBST(LIBRCD_VERSION_MINOR)
-AC_SUBST(LIBRCD_VERSION_SUBMINOR)
-AC_SUBST(LIBRCD_VERSION_INFO)
-
-AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
-
-AC_ARG_ENABLE( latin,
- [ --disable-latin disable detection of ISO-8859-1],,
- disable_latin="yes")
-
-if test "x$disable_latin" = "xyes"; then
- AC_DEFINE(DETECT_LATIN,1,[Defines if ISO-8859-1 detection is enabled])
-fi
-
-AC_PROG_CC
-AC_PROG_INSTALL
-AM_PROG_LIBTOOL
-
-AC_PATH_PROG(RM, rm, /bin/rm)
-AC_PATH_PROG(MV, mv, /bin/mv)
-AC_PATH_PROG(TAR, tar, /bin/tar)
-
-dnl Checks for programs.
-
-dnl Checks for libraries.
-
-dnl Checks for header files.
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-
-dnl Checks for library functions.
-
-AC_OUTPUT(src/Makefile examples/Makefile statgen/Makefile Makefile librcd.spec librcd.pc)