summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2014-06-12 19:03:18 +0200
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2014-06-12 19:03:18 +0200
commitf5c9a8080f0932335457fe5cb0dff38c2d491cb5 (patch)
tree26ec33246b846a54a6a52747519ca80c3c1000b7 /src/CMakeLists.txt
parent89f93872d8e024c761cc55335518f7d48d414fdb (diff)
downloadlibrcc-f5c9a8080f0932335457fe5cb0dff38c2d491cb5.tar.gz
librcc-f5c9a8080f0932335457fe5cb0dff38c2d491cb5.tar.bz2
librcc-f5c9a8080f0932335457fe5cb0dff38c2d491cb5.tar.xz
librcc-f5c9a8080f0932335457fe5cb0dff38c2d491cb5.zip
Mingw compatibility fixes by trialuser
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7477fd9..8b49d55 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -66,5 +66,5 @@ SET(rcc_SRCS
${HEADERS}
)
-ADD_LIBRARY(rcc ${rcc_SRCS})
+ADD_LIBRARY(rcc SHARED ${rcc_SRCS})
TARGET_LINK_LIBRARIES(rcc ${LIBXML2_LIBRARY} ${ICONV_LIBRARY} ${ENCA_LIBRARY} ${LIBRCD_LIBRARY} ${ZLIB_LIBRARY} ${WSOCK_LIBRARY})