summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorTimo Dritschler <timo.dritschler@kit.edu>2014-05-27 15:30:08 +0200
committerTimo Dritschler <timo.dritschler@kit.edu>2014-05-27 15:31:04 +0200
commit69f57959d50cf08d063484551f15f6990582953d (patch)
tree5b445bc327ad2da38d26837b8693a16421d2111a /test/CMakeLists.txt
parent72cb71c99131db200871dac9e17acefdf97292e7 (diff)
downloadkiro-69f57959d50cf08d063484551f15f6990582953d.tar.gz
kiro-69f57959d50cf08d063484551f15f6990582953d.tar.bz2
kiro-69f57959d50cf08d063484551f15f6990582953d.tar.xz
kiro-69f57959d50cf08d063484551f15f6990582953d.zip
Changed build system to CMake
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..849d0b3
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,8 @@
+include_directories(${KIRO_SOURCE_DIR}/src)
+link_directories(${KIRO_BINARY_DIR}/src)
+
+add_executable(client test-client.c)
+target_link_libraries(client kiro SDL m gobject-2.0 glib-2.0)
+
+add_executable(server test-server.c)
+target_link_libraries(server kiro gobject-2.0 glib-2.0)