summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorTimo Dritschler <timo.dritschler@kit.edu>2015-03-09 16:42:34 +0100
committerTimo Dritschler <timo.dritschler@kit.edu>2015-03-09 17:35:40 +0100
commit3f65e7bc3386d1a761fc33683c005181184fd8e4 (patch)
tree6925a2e3ce12e02d0862b4bb57203bb07ee5d27f /test/CMakeLists.txt
parent138cf0430005193de7777ebf72328f819876e775 (diff)
downloadkiro-3f65e7bc3386d1a761fc33683c005181184fd8e4.tar.gz
kiro-3f65e7bc3386d1a761fc33683c005181184fd8e4.tar.bz2
kiro-3f65e7bc3386d1a761fc33683c005181184fd8e4.tar.xz
kiro-3f65e7bc3386d1a761fc33683c005181184fd8e4.zip
Added kiro-test-partial tool for kiro_sync_partial testing
Changed KiroSbSyncCallbacks to pass generic void* userdata instead of KiroSb*
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 35b0531..4ae047b 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -18,6 +18,8 @@ add_executable(kiro-test-bandwidth test-client-bandwidth.c)
target_link_libraries(kiro-test-bandwidth kiro gobject-2.0 glib-2.0)
add_executable(kiro-server test-server.c)
target_link_libraries(kiro-server kiro gobject-2.0 glib-2.0)
+add_executable(kiro-test-partial test-partial.c)
+target_link_libraries(kiro-test-partial kiro gobject-2.0 glib-2.0)
install(TARGETS kiro-test-bandwidth kiro-test-latency kiro-server
RUNTIME DESTINATION ${KIRO_BINDIR})