summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimo Dritschler <timo.dritschler@kit.edu>2015-01-21 16:12:28 +0100
committerTimo Dritschler <timo.dritschler@kit.edu>2015-01-21 16:12:28 +0100
commitcac103dc4d9016cb07a2da991b3338a01a753b30 (patch)
treecf87e6e2d9d790e9327284806c23ccac662c9be7 /CMakeLists.txt
parent3cceb501d225b314a4f3188c32bd630cf306cd00 (diff)
downloadkiro-cac103dc4d9016cb07a2da991b3338a01a753b30.tar.gz
kiro-cac103dc4d9016cb07a2da991b3338a01a753b30.tar.bz2
kiro-cac103dc4d9016cb07a2da991b3338a01a753b30.tar.xz
kiro-cac103dc4d9016cb07a2da991b3338a01a753b30.zip
Fixed a bug in KiroClient when connection fails during setup
Added early-out functionality to all KIRO interfaces to prevent segfaults when passing a NULL pointer
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cad6854..a5db2aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,8 +26,8 @@ else()
endif()
find_package(PkgConfig)
-pkg_check_modules(GLIB2 glib-2.0>=2.24 REQUIRED)
-pkg_check_modules(GOBJECT2 gobject-2.0>=2.24 REQUIRED)
+pkg_check_modules(GLIB2 glib-2.0>=2.32 REQUIRED)
+pkg_check_modules(GOBJECT2 gobject-2.0>=2.32 REQUIRED)
include_directories(
SYSTEM