summaryrefslogtreecommitdiffstats
path: root/pywrap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pywrap/CMakeLists.txt')
-rw-r--r--pywrap/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/pywrap/CMakeLists.txt b/pywrap/CMakeLists.txt
index e5f7ea7..d4d75d1 100644
--- a/pywrap/CMakeLists.txt
+++ b/pywrap/CMakeLists.txt
@@ -8,14 +8,13 @@ include_directories(
${UTHASH_INCLUDE_DIRS}
)
+set(HEADERS pcipywrap.h)
+
#Creating python wrapping
INCLUDE(${SWIG_USE_FILE})
-
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
-
SET(CMAKE_SWIG_FLAGS "")
-SET_SOURCE_FILES_PROPERTIES(pcipywrap.i PROPERTIES SWIG_FLAGS "-includeall")
SWIG_ADD_MODULE(pcipywrap python pcipywrap.i pcipywrap.c)
SWIG_LINK_LIBRARIES(pcipywrap ${PYTHON_LIBRARIES} pcilib)