summaryrefslogtreecommitdiffstats
path: root/pcitool/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2016-02-04 01:18:33 +0100
committerSuren A. Chilingaryan <csa@suren.me>2016-02-04 01:18:33 +0100
commit0e12e11ed817d66ff1e9246a32931e14e4fa6700 (patch)
tree6d2a2f2c6f374a0df45605701a0f736f2993a8a5 /pcitool/CMakeLists.txt
parent333fe52eb3c7876cfe668dfe0445d34c46989d73 (diff)
downloadpcitool-0e12e11ed817d66ff1e9246a32931e14e4fa6700.tar.gz
pcitool-0e12e11ed817d66ff1e9246a32931e14e4fa6700.tar.bz2
pcitool-0e12e11ed817d66ff1e9246a32931e14e4fa6700.tar.xz
pcitool-0e12e11ed817d66ff1e9246a32931e14e4fa6700.zip
Add build information
Diffstat (limited to 'pcitool/CMakeLists.txt')
-rw-r--r--pcitool/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/pcitool/CMakeLists.txt b/pcitool/CMakeLists.txt
index 2f3639f..d8b5a6c 100644
--- a/pcitool/CMakeLists.txt
+++ b/pcitool/CMakeLists.txt
@@ -13,9 +13,9 @@ link_directories(
)
if (NOT DISABLE_PCITOOL)
- add_executable(pci cli.c sysinfo.c formaters.c)
- set(HEADERS ${HEADERS} sysinfo.h formaters.h)
- add_dependencies(pci pcilib)
+ set(HEADERS ${HEADERS} sysinfo.h formaters.h buildinfo.h)
+ add_executable(pci cli.c sysinfo.c formaters.c buildinfo.c)
+ add_dependencies(pci build pcilib)
target_link_libraries(pci pcilib ${FASTWRITER_LIBRARIES})
set_target_properties(pci PROPERTIES
LINK_FLAGS "${CMAKE_THREAD_LIBS_INIT} ${EXTRA_SYSTEM_LIBS}"