summaryrefslogtreecommitdiffstats
path: root/pcilib/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2015-08-12 20:25:35 +0200
committerSuren A. Chilingaryan <csa@suren.me>2015-08-12 20:25:35 +0200
commit55783eb24e983786056f4ba7925aa23fca13c79e (patch)
tree3a4c9bd7523117f790b411ba8fe4b3907d5e72bc /pcilib/CMakeLists.txt
parent38fdfd8b69ba5ae747915bbdbb3066d29611437d (diff)
downloadpcitool-55783eb24e983786056f4ba7925aa23fca13c79e.tar.gz
pcitool-55783eb24e983786056f4ba7925aa23fca13c79e.tar.bz2
pcitool-55783eb24e983786056f4ba7925aa23fca13c79e.tar.xz
pcitool-55783eb24e983786056f4ba7925aa23fca13c79e.zip
Fix support of older systems: Remove C11 derective and add rt library to the link list
Diffstat (limited to 'pcilib/CMakeLists.txt')
-rw-r--r--pcilib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/pcilib/CMakeLists.txt b/pcilib/CMakeLists.txt
index 79b15c2..be59cb7 100644
--- a/pcilib/CMakeLists.txt
+++ b/pcilib/CMakeLists.txt
@@ -5,7 +5,7 @@ include_directories(
set(HEADERS pcilib.h pci.h export.h bar.h fifo.h model.h bank.h register.h kmem.h irq.h locking.h lock.h dma.h event.h plugin.h tools.h error.h debug.h env.h version.h config.h)
add_library(pcilib SHARED pci.c export.c bar.c fifo.c model.c bank.c register.c kmem.c irq.c locking.c lock.c dma.c event.c plugin.c tools.c error.c debug.c env.c )
-target_link_libraries(pcilib dma protocols ${CMAKE_THREAD_LIBS_INIT} ${UFODECODE_LIBRARIES} ${CMAKE_DL_LIBS})
+target_link_libraries(pcilib dma protocols ${CMAKE_THREAD_LIBS_INIT} ${UFODECODE_LIBRARIES} ${CMAKE_DL_LIBS} ${EXTRA_SYSTEM_LIBS})
add_dependencies(pcilib dma protocols)
install(TARGETS pcilib