summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2012-08-18 03:37:03 +0200
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2012-08-18 03:37:03 +0200
commita577cc5b8ef1f477e21f5f1c867c2936f86afa62 (patch)
tree5083c912e4db3e4a2fe65c0beeb7461262861ccd /CMakeLists.txt
parent765adcc5aa9e7456cb35f906b6f33381feb92cd7 (diff)
downloadipecamera-a577cc5b8ef1f477e21f5f1c867c2936f86afa62.tar.gz
ipecamera-a577cc5b8ef1f477e21f5f1c867c2936f86afa62.tar.bz2
ipecamera-a577cc5b8ef1f477e21f5f1c867c2936f86afa62.tar.xz
ipecamera-a577cc5b8ef1f477e21f5f1c867c2936f86afa62.zip
Use add_library to link against pthread
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54a7120..80355c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,13 +27,12 @@ add_subdirectory(ipecamera)
add_subdirectory(pcitool)
add_library(pcilib SHARED pci.c register.c kmem.c irq.c dma.c event.c default.c tools.c error.c)
-target_link_libraries(pcilib ufodecode dma ipecamera)
+target_link_libraries(pcilib ufodecode dma ipecamera ${CMAKE_THREAD_LIBS_INIT})
add_dependencies(pcilib dma ipecamera)
set_target_properties(pcilib PROPERTIES
VERSION ${PCILIB_VERSION}
SOVERSION ${PCILIB_ABI_VERSION}
- LINK_FLAGS ${CMAKE_THREAD_LIBS_INIT}
# LINK_FLAGS "-pthread"
# LINK_FLAGS "-pthread -Wl,--whole-archive,dma/libdma.a,ipecamera/libipecamera.a,--no-whole-archive"
)