summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2012-02-04 19:01:00 +0100
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2012-02-04 19:01:00 +0100
commit8e63b1c9c834035678159ef883ed0b6be107dc09 (patch)
tree0a6c7cf484e8c051a44a70bc4c6ad7acc73966df /CMakeLists.txt
parent0408a26c145fe2188bdb86314b1f559044cba356 (diff)
downloadipecamera-8e63b1c9c834035678159ef883ed0b6be107dc09.tar.gz
ipecamera-8e63b1c9c834035678159ef883ed0b6be107dc09.tar.bz2
ipecamera-8e63b1c9c834035678159ef883ed0b6be107dc09.tar.xz
ipecamera-8e63b1c9c834035678159ef883ed0b6be107dc09.zip
Link pci with pthread
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e484f1d..b26fdee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,9 @@ if (NOT DISABLE_PCITOOL)
add_executable(pci cli.c)
add_dependencies(pci pcitool)
target_link_libraries(pci pcilib pcitool fastwriter)
+ set_target_properties(pci PROPERTIES
+ LINK_FLAGS "-pthread"
+ )
endif (NOT DISABLE_PCITOOL)
#set_target_properties(pci PROPERTIES