summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2015-07-24 14:06:30 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2015-07-24 14:06:30 +0200
commit84b10f0787095565e095d00501ecde1323ba72ed (patch)
tree6b74233dcb1f294e73b5428482ea958871b66634 /CMakeLists.txt
parent6844404223d1b19be830e1b2dee550955680556c (diff)
downloaduca-ufo-84b10f0787095565e095d00501ecde1323ba72ed.tar.gz
uca-ufo-84b10f0787095565e095d00501ecde1323ba72ed.tar.bz2
uca-ufo-84b10f0787095565e095d00501ecde1323ba72ed.tar.xz
uca-ufo-84b10f0787095565e095d00501ecde1323ba72ed.zip
Update against current pcilib
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0f810a7..cc840a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,24 +13,23 @@ add_definitions(-DG_LOG_DOMAIN="Uca-Ufo")
pkg_check_modules(UCA libuca>=2.0.0 REQUIRED)
pkg_check_modules(GIO2 gio-2.0>=2.24 REQUIRED)
+pkg_check_modules(PCITOOL pcitool>=0.2.0 REQUIRED)
pkg_check_variable(libuca plugindir)
# --- Plugin specific ---------------------------------------------------------
-find_package(IPE REQUIRED)
-
include_directories(
${UCA_INCLUDE_DIRS}
- ${IPE_INCLUDE_DIRS}
+ ${PCITOOL_INCLUDE_DIRS}
${GIO2_INCLUDE_DIRS})
add_library(ucaufo SHARED uca-ufo-camera.c)
target_link_libraries(ucaufo
${UCA_LIBRARIES}
- ${GIO2_LIBRARIES}
- ${IPE_LIBRARIES})
+ ${PCITOOL_LIBRARIES}
+ ${GIO2_LIBRARIES})
install(TARGETS ucaufo
LIBRARY DESTINATION ${LIBUCA_PLUGINDIR})