summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvagrant <vagrant@localhost.localdomain>2019-01-21 16:41:10 +0000
committervagrant <vagrant@localhost.localdomain>2019-01-21 16:41:10 +0000
commit5e436eab5cea50569df9c85159be69d8e88688f0 (patch)
treead233a03a25e587f09ebee23fc8ad48a7c2892dd /CMakeLists.txt
parent204dc742ee5a8fda3f168b3e84632f5cdb75ce2e (diff)
downloadregularization-5e436eab5cea50569df9c85159be69d8e88688f0.tar.gz
regularization-5e436eab5cea50569df9c85159be69d8e88688f0.tar.bz2
regularization-5e436eab5cea50569df9c85159be69d8e88688f0.tar.xz
regularization-5e436eab5cea50569df9c85159be69d8e88688f0.zip
UPDATE: propagate CIL_VERSION
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e3e59e9..b95107a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,8 +26,9 @@ set (CIL_VERSION_MINOR 10)
set (CIL_VERSION_PATCH 2)
# set (CIL_VERSION '${CIL_VERSION_MAJOR}.${CIL_VERSION_MINOR}.${CIL_VERSION_PATCH}' CACHE INTERNAL "Core Imaging Library version" FORCE)
-# get CIL_VERSION from environment variable
+# get CIL_VERSION from environment variable and set it in cmake
set (CIL_VERSION $ENV{CIL_VERSION} CACHE INTERNAL "Core Imaging Library version" FORCE)
+message(STATUS "CIL_VERSION set to " ${CIL_VERSION})
# set the Python variables for the Conda environment
#include(${CMAKE_SOURCE_DIR}/CMake/FindAnacondaEnvironment.cmake)