summaryrefslogtreecommitdiffstats
path: root/recipe/meta.yaml
diff options
context:
space:
mode:
Diffstat (limited to 'recipe/meta.yaml')
-rw-r--r--recipe/meta.yaml45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipe/meta.yaml b/recipe/meta.yaml
new file mode 100644
index 0000000..fee8e87
--- /dev/null
+++ b/recipe/meta.yaml
@@ -0,0 +1,45 @@
+package:
+ name: ccpi-framework
+ version: {{ environ['CIL_VERSION'] }}
+
+build:
+ preserve_egg_dir: False
+ script_env:
+ - CIL_VERSION
+ #number: 0
+
+test:
+ requires:
+ - python-wget
+ - cvxpy # [ unix and py36 and np115 ]
+
+ source_files:
+ - ./Wrappers/Python/test # [win]
+ - ./ccpi/Wrappers/Python/test # [not win]
+
+ commands:
+ - python -c "import os; print ('TESTING IN THIS DIRECTORY' , os.getcwd())"
+ - python -m unittest discover Wrappers/Python/test # [win]
+ - python -m unittest discover -s ccpi/Wrappers/Python/test # [not win]
+
+requirements:
+ build:
+ - {{ pin_compatible('numpy', max_pin='x.x') }}
+ - python
+ - setuptools
+ - cmake
+
+ run:
+ - {{ pin_compatible('numpy', max_pin='x.x') }}
+ - python
+ - numpy
+ - scipy
+ - matplotlib
+ - h5py
+ - pillow
+ - libgcc-ng # [not win]
+
+about:
+ home: http://www.ccpi.ac.uk
+ license: Apache 2.0 License
+ summary: 'CCPi Framework'