summaryrefslogtreecommitdiffstats
path: root/utils/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'utils/setup.py')
-rw-r--r--utils/setup.py9
1 files changed, 2 insertions, 7 deletions
diff --git a/utils/setup.py b/utils/setup.py
index eac1b4b2e..3518581e7 100644
--- a/utils/setup.py
+++ b/utils/setup.py
@@ -47,7 +47,7 @@ setup(
# your project is installed. For an analysis of "install_requires" vs pip's
# requirements files see:
# https://packaging.python.org/en/latest/requirements.html
- install_requires=['click', 'PyYAML'],
+ install_requires=['click', 'PyYAML', 'ansible'],
# List additional groups of dependencies here (e.g. development
# dependencies). You can install these using the following syntax,
@@ -62,14 +62,9 @@ setup(
# installed, specify them here. If using Python 2.6 or less, then these
# have to be included in MANIFEST.in as well.
package_data={
- 'ooinstall': ['ansible.cfg', 'ansible_plugins/*'],
+ 'ooinstall': ['ansible.cfg', 'ansible-quiet.cfg', 'ansible_plugins/*'],
},
- # Although 'package_data' is the preferred approach, in some case you may
- # need to place data files outside of your packages. See:
- # http://docs.python.org/3.4/distutils/setupscript.html#installing-additional-files # noqa
- # In this case, 'data_file' will be installed into '<sys.prefix>/my_data'
- #data_files=[('my_data', ['data/data_file'])],
tests_require=['nose'],
test_suite='nose.collector',