summaryrefslogtreecommitdiffstats
path: root/utils/setup.py
diff options
context:
space:
mode:
authorJason DeTiberus <detiber@gmail.com>2017-02-20 12:36:23 -0500
committerGitHub <noreply@github.com>2017-02-20 12:36:23 -0500
commit3d80a37685da4948aad62419e49335cb5a140826 (patch)
tree2dabc7c9bee247b9e85a10ed4178765a54f7fe6c /utils/setup.py
parentbc26f6b0fc90d4501161e16dcf68130d03ca06a7 (diff)
parentdf1fd5b8f97c69eef10c02f317b62755c4519d92 (diff)
downloadopenshift-3d80a37685da4948aad62419e49335cb5a140826.tar.gz
openshift-3d80a37685da4948aad62419e49335cb5a140826.tar.bz2
openshift-3d80a37685da4948aad62419e49335cb5a140826.tar.xz
openshift-3d80a37685da4948aad62419e49335cb5a140826.zip
Merge pull request #3419 from rhcarvalho/pytest
Migrate from nose to pytest
Diffstat (limited to 'utils/setup.py')
-rw-r--r--utils/setup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/utils/setup.py b/utils/setup.py
index 3518581e7..20e3d81dc 100644
--- a/utils/setup.py
+++ b/utils/setup.py
@@ -40,7 +40,7 @@ setup(
# simple. Or you can use find_packages().
#packages=find_packages(exclude=['contrib', 'docs', 'tests*']),
packages=['ooinstall'],
- package_dir={'ooinstall': 'src/ooinstall'},
+ package_dir={'': 'src'},
# List run-time dependencies here. These will be installed by pip when
@@ -65,9 +65,8 @@ setup(
'ooinstall': ['ansible.cfg', 'ansible-quiet.cfg', 'ansible_plugins/*'],
},
- tests_require=['nose'],
-
- test_suite='nose.collector',
+ setup_requires=['pytest-runner'],
+ tests_require=['pytest'],
# To provide executable scripts, use entry points in preference to the
# "scripts" keyword. Entry points provide cross-platform support and allow