diff options
author | Steve Milner <smilner@redhat.com> | 2017-01-12 15:14:05 -0500 |
---|---|---|
committer | Steve Milner <smilner@redhat.com> | 2017-01-12 15:14:05 -0500 |
commit | 9a259ef6926049011746d68bdea34404006e8f6a (patch) | |
tree | e49cb49418c07ffad46ab1812032f66cb54cacab /setup.py | |
parent | f03d2d42a2b419e9f3cbd3eeb17107e8b76f9a8f (diff) | |
download | openshift-9a259ef6926049011746d68bdea34404006e8f6a.tar.gz openshift-9a259ef6926049011746d68bdea34404006e8f6a.tar.bz2 openshift-9a259ef6926049011746d68bdea34404006e8f6a.tar.xz openshift-9a259ef6926049011746d68bdea34404006e8f6a.zip |
Added setup.py to flake8 tests
Added setup.py to flake8 tests since it is code. Also minor updates to
slightly modernize.
Note: In the future {#} should probably be ported to {} as numbering is
no longer needed (and disliked by many).
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -17,6 +17,7 @@ from yamllint.config import YamlLintConfig from yamllint.cli import Format from yamllint import linter + def find_files(base_dir, exclude_dirs, include_dirs, file_regex): ''' find files matching file_regex ''' found = [] @@ -111,7 +112,8 @@ class OpenShiftAnsibleYamlLint(Command): if has_errors or has_warnings: print('yammlint issues found') - exit(1) + raise SystemExit(1) + class OpenShiftAnsiblePylint(PylintCommand): ''' Class to override the default behavior of PylintCommand ''' |