diff options
author | Russell Teague <rteague@redhat.com> | 2017-12-08 08:04:21 -0500 |
---|---|---|
committer | Russell Teague <rteague@redhat.com> | 2017-12-08 08:04:58 -0500 |
commit | 7834423c6da99fdf5179d3fee11a94bcb1b6ab6d (patch) | |
tree | 051d9928e243ed8486a5394113331535bcb13999 /setup.py | |
parent | bb54b2f2b5a34f1c4005aa24877ebb23d8a4607d (diff) | |
download | openshift-7834423c6da99fdf5179d3fee11a94bcb1b6ab6d.tar.gz openshift-7834423c6da99fdf5179d3fee11a94bcb1b6ab6d.tar.bz2 openshift-7834423c6da99fdf5179d3fee11a94bcb1b6ab6d.tar.xz openshift-7834423c6da99fdf5179d3fee11a94bcb1b6ab6d.zip |
Update deprecation checks - include:
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -334,9 +334,9 @@ class OpenShiftAnsibleSyntaxCheck(Command): result = self.deprecate_jinja2_in_when(yaml_contents, yaml_file) has_errors = result or has_errors - # TODO (rteague): This test will be enabled once we move to Ansible 2.4 - # result = self.deprecate_include(yaml_contents, yaml_file) - # has_errors = result or has_errors + # Check for usage of include: directive + result = self.deprecate_include(yaml_contents, yaml_file) + has_errors = result or has_errors if not has_errors: print('...PASSED') |